evitare errori dovuti alla versione quando si usano le googlemaps

Questa mattina mi sono trovato un paio di pagine conteneti google maps, che avevo fatto tempo fa, completmente inutilizzabili.
Dopo una breve analisi mi sono accorto che il problema era dovuto all’aver sviluppato le pagine per una precisa versione delle api (per l’esattezza la 2.46) includendo direttamente lo script e facendo la classica chiamata :

<script src="http://maps.google.com/maps?file=api&amp;v=2&amp;key=abcdefg"
type="text/javascript"></script>

prima di tale inclusione, invertendo le due cose tutto si è risolto.
Un altra soluzione possibile sarebbe stata di specificare la versione usata delle api nella variabile v sostituendo v=2 con v=2.46.

Annunci

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger hanno fatto clic su Mi Piace per questo: